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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis
o Titles of publications
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon or a partial view of the ribbon is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This Getting Started Guide is written for Maxwell beginners and for experienced users who
would like to quickly re-familiarize themselves with the capabilities of Maxwell. This guide leads
you step-by-step through creating, solving, and analyzing the results of solving a rotational
actuator magnetostatic problem.

By following the steps in this guide, you will learn how to perform the following tasks:

l Draw a geometric model
l Modify a model’s design parameters
l Assign variables to a model’s design parameters
l Specify solution settings for a design
l Validate a design’s setup
l Run a Maxwell simulation
l Plot the magnetic flux density vector
l Run a parametric analysis
l Create an animation using saved parametric field data

Note: This guide is designed to help you build and simulate a rotational actuator in
Ansys Maxwell. If you would like to skip the model creation process or need help
trouble shooting the model you created, a prebuilt version rotational actuator is located
in \\AnsysEM\VersionNumber\OS\Examples\Maxwell\Actuators.

Maxwell Solution Types

Ansys Maxwell is an interactive software package that uses finite element analysis (FEA) to
simulate (solve) electromagnetic field problems. Maxwell integrates with other Ansys software
packages to perform complex tasks while remaining simple to use. Maxwell incorporates both a
set of 2D solvers and 3D solvers in an integrated user interface. This guide will focus on 3D
capabilities. 2D problems examples are cover in a separate 2D Getting Started Guide.

The following types of stand-alone solutions are supported by Maxwell 3D:

l Magnetostatic linear and nonlinear 3D fields caused by a user-specified distribution of
DC current density and permanent or externally applied magnetic fields. Materials can be
nonlinear and anisotropic. Additional quantities that can be computed include torque,
force, and self and mutual inductances.

l Harmonic (sinusoidal variation in time) steady-state magnetic fields with pulsation-
induced eddy currents in massive solid conductors caused by one of the following:

l A user-specified distribution of AC currents (all with the same frequency but with
possibly different initial phase angles).

Getting Started with Maxwell®: Designing a Rotational Actuator
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l Externally applied magnetic fields.

This solution includes displacement currents for calculating near field electromagnetic
wave radiation.

l Transient (time domain) magnetic fields caused by permanent magnets, conductors,
and windings supplied by voltage and/or current sources with arbitrary variation as
functions of time. Rotational or translational motion effects can be included in the
simulation. This option uses the TAU solver.

l A-Phi Formulation: This solver is an alternative to the transient TAU solver. A is the
Magnetic Vector Potential and ϕ(Phi) is the Electric Scalar Potential. The A-Phi solver
allows multi-terminal conductors, and it supports sources of various types on a single
conduction path; the J and E fields are calculated directly because it is a first-order
approximation. This option is useful for application fields in Power Electronics, Bus Bars,
PCBA, etc., where the voltage distribution in multiple conductors is essential.

l Electrostatic 3D fields caused by a user-specified distribution of voltages and charges in
non-conducting regions. Additional quantities that can be computed include torque, force,
and capacitances.

l Electric DC Conduction 3D fields in conductors characterized by a spatial distribution of
voltage, electric field, and current density. Power loss can also be computed. In addition,
optional simulation of fields in insulating materials is supported.

l Transient (time domain) 3D Electric fields caused by time dependent voltage, current
and charge distributions. All sources are arbitrary functions of time.

l AC Conduction 3D electric fields and losses arising in conductors and imperfect (lossy)
dielectrics from the application of an alternating (AC) voltage or external current to the
electrodes. The AC conduction field solver assumes that all sources are sinusoids
oscillating at the same frequency.

In addition, Maxwell may be coupled with other simulators to provide a greater range of solution
capability. Couplings to Workbench for stress analysis, HFSS for ferrite analysis, Fluent for
thermal analysis, and Twin Builder for Finite Element/Circuit co-simulation are all supported.

The Maxwell Desktop
The following graphic shows the different sections of the Maxwell desktop:
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General Procedure for Setting Up Maxwell Designs

You are not required to follow a specific order when setting up your Maxwell design. However,
the following order is recommended, particularly for new users:

1. Open Ansys Electronics Desktop by double-clicking the desktop icon or by clicking Start >
Programs > Ansys EM Suite [version] > Ansys Electronics Desktop [version] from the
Windows taskbar.

2. Add a Maxwell 3D design and save the new project.
3. Draw the geometry of the model.
4. Optionally, modify the model's design parameters.
5. Assign variables to design parameters.
6. Assign excitations and boundary conditions.
7. Specify solution settings.
8. Run a Maxwell simulation.
9. Create postprocessing plots.
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Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: Designing a Rotational Actuator

10. Create a parametric analysis.
11. Create a field animation of the parametric analysis results.

About the Example Design

The application described in this Getting Started guide is an extension of the TEAMWorkshop
Problem 24 rotational actuator design. The geometry is shown below:

The outer part is a ferromagnetic nonlinear armature carrying two coils. The inner part is made of
the same nonlinear material and can rotate around an axis. The inner and outer parts of the
device are coaxial.

The field distribution will likely cause the flux density to concentrate in the two steel armatures in
the regions where the distance between them is minimal. The expected edge effect will then
further increase the field concentration.

In this example, we will compute the torque acting on the inner armature and the flux linkage of
the two coils. For a presentation of the results and the corresponding FEM code, see the IEEE
Transactions on Magnetics, Vol 38, No. 2, March 2002, pp 609-612.
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2 - Setting Up the Design
In this chapter, you will complete the following tasks:

l Open and save a new project.
l Insert a new Maxwell design into the project.
l Select a solution type for the project.
l Set the drawing units for the design.

Open Maxwell and Save a New Project
A project is a collection of one or more designs that is saved in a single *.aedt file. A new project
is automatically created when Ansys Electronics Desktop is launched.

To open Ansys Electronics Desktop, add a new Maxwell 3D design, and save the default project
with a new name:

1. Double-click the Ansys Electronics Desktop icon on your desktop to launch
Ansys Electronics Desktop.

l You can also start Ansys Electronics Desktop by clicking Start > Programs >
Ansys EM Suite [version] > Ansys Electronics Desktop [version] fromWindows.

2. Click Project > Insert Maxwell 3D Design.

The new design is listed in the Project Manager tree. By default, it is named
Maxwell3DDesign1. TheModeler window appears to the right of the Project Manager
window.

3. Click File > Save As.

The Save As dialog box appears.

4. Locate and select the folder in which you want to save the project.
5. Type Rotational_actuator in the File name box, and click Save.

The project is saved in the specified folder under the name Rotational_actuator.aedt.

6. Rename the design:
a. Right-clickMaxwell3DDesign1.

A shortcut menu appears.

b. Select Rename.

The design name becomes highlighted and editable.

c. Type Rotational_actuator as the name for the design, and press Enter.

The project and design are now both named Rotational_actuator.

Getting Started with Maxwell®: Designing a Rotational Actuator
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Specify a Solution Type
As mentioned in the introduction, multiple solution types are available, depending on the specific
application. For this design, choose aMagnetostatic solution.

1. ClickMaxwell 3D > Solution Type from the menus.

The Solution Type dialog box appears.

2. Select theMagnetostatic radio button.
3. ClickOK.

Set the Drawing Units
1. ClickModeler > Units.

The Set Model Units and Max Extent dialog box appears.

2. Selectmm from the Select units drop-down menu.
3. ClickOK.

Setting Up the Design 2-2
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3 - Creating the Geometric Model
In this chapter you will complete the following tasks:

l Set the drawing plane and movement mode
l Create the outer armature of the actuator by subtracting and uniting
objects

l Create the inner armature of the actuator
l Create the coils
l Create the coil terminals
l Create the background object
l Finalize the geometry by rotating the inner arm

Set the Drawing Plane and Movement Mode
Before creating the geometry, make sure the XY drawing plane is selected and 3D is selected as
the movement mode.

1. Click on the Draw tab.
2. From the Grid menu, select XY for the Drawing plane.
3. Select 3D for theMovement mode.

Getting Started with Maxwell®: Designing a Rotational Actuator
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Note: If you have adjusted the size of the Ansys Electronic Desktop window to make it
smaller, theGridmenu may not be visible. In that case, it is available from the
Visibility drop-down menu, which appears when the Ansys Electronic Desktop
window has been made smaller.

Create the Outer Armature Object
The outer armature consists of two cylinders (for an outer and inner radius) that are subtracted to
leave the armature. Magnetic poles are then added to the armature object.

Draw the Outer Cylinder
Create the outer radius of the outer armature object.

To create the outer cylinder:

1. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawingmode.

2. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin for
the coordinate system, and press the Tab key to jump to the manual entry area in the
Status Bar at the bottom of the screen.

3. Notice the Status Bar is prompting for Radius of the cylinder. Type 104.5 for the radius in
the dX box, and ensure that dY and dZ are set to zero. Press Enter.

4. The Status Bar is now prompting for height of the cylinder. Type 25.4 for the height in the
dZ box, and press Enter. The cylinder is created and the default properties appear in the
Properties Window.

Note: If the Properties window is not visible, from the menu bar, select View
> Properties. You can also open the Properties window by double-clicking an
entry in the history tree. This example assumes that the Properties window is
always open.

Creating the Geometric Model 3-2
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5. In the Attribute tab, change the Name (currently Cylinder1) toOuter_arm.
6. Change the color of the cylinder to red:

a. In the Color row, click the Edit button.

The Color palette dialog box appears.

b. Select any of the red shades from the Basic colors group, and clickOK to return to
the Properties window.

7. Set the transparency to 0.6:
a. Click the button for the Transparent property.

The Set Transparency dialog box appears.

b. Type 0.6 in the text box, and clickOK to return to the Properties window.

Note: To view and edit geometric data, double-click the CreateCylinder entry in
theModel history tree window to open the Command tab.

8. If you are using the pop-up Properties dialog box, clickOK to close the Properties
window. A cylinder namedOuter_arm is drawn.

View the Entire Cylinder
It is easier to view the model you are drawing if you set it to fit the screen.

To fit the entire model on the screen:

Creating the Geometric Model 3-3
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l Click View > Fit All > All Views; or use the keyboard shortcut Ctrl+D.

Draw the Inner Cylinder
Add the inner radius for the outer armature object.

To create the inner cylinder:

1. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawingmode.

2. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin for
the coordinate system. Press Tab to navigate to the keyboard entry area on the Status
Bar.

3. Type 83.1 for the radius in the dX box at the bottom of the screen, and press Enter.

Note: Use the Tab key to navigate between value fields (from X to Y to Z and
from dX to dY to dZ).

4. Type 25.4 for the height in the dZ box, and press Enter.

The Properties window appears.

5. Click the Attribute tab.
6. Change the Name to Cylinder_tool.

Creating the Geometric Model 3-4
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Subtract the Cylinders
Subtract Cylinder_tool fromOuter_arm.

To subtract the second cylinder from the first:

1. In the history tree, expand theModel\Solids entry, and select theOuter_arm cylinder,
press and hold down Ctrl, and select the Cylinder_tool cylinder.

2. ClickModeler > Boolean > Subtract.

The Subtract dialog box appears.

Note: The first object selected appears under Blank Parts, and the second
object selected appears under Tool Parts. Tool parts are removed during a
Boolean operation (unless cloned) and the final part takes on the name and other
characteristics of the Blank Part.

3. If necessary, move theOuter_arm object to the Blank Parts list and the Cylinder_tool
object to the Tool Parts list. To move an object from one list to another, select it, and click
the appropriate arrow.

4. ClickOK.

Add the Poles to the Outer Armature
Add two magnetic poles to the outer armature. To do so, you need to create a box, move the box
into the position for the poles, and use theMirror command to create a duplicate of the box.
Then unite the three model objects, and subtract a newly created cylinder to arrive at the final
shape.

To create the box for the outer armature magnetic poles:

1. Click Draw > Box.
2. Type the box position (-13.9, 0, 0) in the X, Y, and Z fields at the bottom of the screen, and

then press Enter.
3. Type the box size (27.8, -40, 25.4) in the dX, dY, dZ fields, and then press Enter.

A box named Box1 is drawn.

Move the Box into a Pole Position
To move the box into the correct position for one of the magnetic poles:

1. Select Box1 from theModel\Solids entry in the history tree.
2. Click Edit > Arrange >Move.
3. Type (0, 0, 0) in the (X, Y, Z) fields as the origin of the move vector and press Enter.

Creating the Geometric Model 3-5
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4. Type (0, -45, 0) in the (dX, dY, dZ) fields as the target point of the move vector and press
Enter.

Create a Duplicate of the Pole Box
To create a duplicate of the box using mirroring:

1. Select Box1 from the history tree.
2. Click Edit > Duplicate >Mirror.
3. Type (0, 0, 0) in the (X, Y, Z) fields as coordinates for the anchor point on the mirror plane,

and press Enter.
4. Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of target point of the vector normal

to the mirror plane, and press Enter.

A second box, named Box1_1, is drawn.

Unite the Outer Armature and Magnetic Pole Boxes

To unite the three objects in the model:

1. In the history tree window, selectOuter_arm, hold down the Ctrl key, and then select
Box1 and Box1_1.

2. SelectModeler > Boolean > Unite.
The first selected object wasOuter_arm; therefore, the default name for the final object is
Outer_arm.

Creating the Geometric Model 3-6
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Finalize the Outer Armature Magnetic Pole Faces
To provide the final shape for the magnetic pole faces:

1. Create a cylinder with the center at (0, 0,0), a radius of 53.75, and a height of 25.4:
a. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawingmode.

b. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin
for the coordinate system. Tab to the keyboard entry area.

c. Type 53.75 for the radius in the dX box at the bottom of the screen and press Enter.
d. Type 25.4 for the height in the dZ box and press Enter.

The Properties window contains the properties of the new cylinder, Cylinder1.

2. Because we will be using a similar cylinder in the next section, we will make a copy of
Cylinder1 for later use.

a. Select Cylinder1.
b. Click Edit > Copy to create a copy of the object on the clipboard.
c. Next select Edit > Paste to paste a new copy, named Cylinder2 in theModel

history tree, into the project at the same location as the original.
d. Right-click Cylinder2 in the history tree, and select View > Hide in Active View.

3. Subtract Cylinder1 fromOuter_arm to achieve the curved edges on the poles:
a. Select theOuter_arm object, press and hold the Ctrl key, and then select

Cylinder1.
b. SelectModeler > Boolean > Subtract.

The Subtract dialog box appears.

Note: Pressing F1 with any dialog on the screen will open the Context-
Sensitive Help system to the appropriate page for that dialog.

c. Make sure theOuter_arm object is in the Blank Parts list and the Cylinder1 object
is in the Tool Parts list.

d. ClickOK.

Creating the Geometric Model 3-7
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TheOuter_arm object should look as shown in the following graphic:

4. Click File > Save to save all of the operations up to this point.

Create the Inner Armature Object
The inner armature consists of two cylinders (for an outer and inner radius) that are subtracted to
leave the armature. Magnetic poles are then added to the armature object. This topic covers
how to

l Draw the Inner Armature Cylinders
l Add the Poles to the Inner Armature

Draw the Inner Armature Cylinders
To draw the inner armature:

1. Create a cylinder called Shaft with the following properties.

Property Value
Center (0, 0, 0)
Radius
(dX)

25.4 mm

Height 25.4 mm
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Property Value
(dZ)

Step-by-step instructions if needed:

a. Click Draw > Cylinder.
b. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin

for the coordinate system. Tab to the keyboard entry area on the Status Bar.
c. Type 25.4 for the radius in the dX box at the bottom of the screen, and press Enter.
d. Type 25.4 for the height in the dZ box, and click Enter.

The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to Shaft.
g. ClickOK.

A cylinder named Shaft is drawn.
2. The properties of Cylinder2 can be modified to create the outer radius of the inner

armature to eliminate the need to draw another object.
a. In the history tree, right-click Cylinder2 and select View > Show in Active View.
b. Select the CreateCylinder entry in the history tree under the Cylinder2 object.

c. In the Properties Window, select the Command tab.
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d. Select the value field containing 53.75 corresponding to Radius. The field becomes
highlighted and editable.

e. Change the value to 38.1 and press Enter. The radius of Cylinder2 is changed in
the modeler window.

f. In the history tree, select cylinder2. The Attribute tab is now visible in the
Properties Window.

g. Change the name of the object by selecting Cylinder2 in the value field
corresponding to Name and entering Inner_arm. Press Enter.

h. Subtract Shaft from Inner_arm:
i. Select Inner_arm, press and hold down the Ctrl key, and select shaft.
ii. SelectModeler > Boolean > Subtract from the menu bar.

The Subtract dialog box appears.
iii. Make sure Inner_arm is in the Blank Parts list and shaft is in the Tool Parts

list.
iv. ClickOK.

Add the Poles to the Inner Armature
To create two magnetic poles for the inner armature, you need to create another box, move the
box into the correct position, and use theMirror command to create a duplicate of the box. Unite
the inner armature with the two boxes, and intersect it with a cylinder to arrive at the final shape.
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Create Box for Inner Armature Magnetic Poles:

1. Click Draw > Box.
2. Type the box position (-12.7, 0, 0) in the X, Y, and Z fields at the bottom of the screen, and

then press Enter.
3. Type the box size (25.4, -20, 25.4) in the dX, dY, dZ fields, and then press Enter.

A box named Box2 is drawn.

Move the Box into Position

1. Select Box2 in the history tree.
2. Select Edit > Arrange >Move.
3. Type (0, 0, 0) in the (X, Y, Z) fields as the origin of the move vector, and press Enter.
4. Type (0, -35, 0) in the (dX, dY, dZ) fields as the target point of the move vector, and press

Enter.

Create a Duplicate of the Box

1. Select Box2 in the history tree.
2. Select Edit > Duplicate >Mirror.
3. Type (0, 0, 0) in the (X, Y, Z) fields as coordinates for the anchor point on the mirror plane,

and press Enter.
4. Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of target point of the vector normal

to the mirror plane, and press Enter.

A box named Box2_1 is drawn.

Unite the Inner Armature and Magnetic Pole Boxes
1. In the history tree, select Inner_arm, press and hold down the Ctrl key, and then select

Box2 and Box2_1.
2. SelectModeler > Boolean > Unite.

Because the first selected object was Inner_arm, the final object name is Inner_arm. The
name of the objects can be changed in the Properties window on the Attribute tab.

Finalize the Inner Armature Magnetic Pole Faces
To provide the final shape for the magnetic pole faces:

1. Create a cylinder with the center at (0, 0,0), a radius of 51.05, and a height of 25.4:
a. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawingmode.
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b. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin
for the coordinate system.

c. Type 51.05 for the radius in the dX box at the bottom of the screen, and press
Enter.

d. Type 25.4 for the height in the dZ box and press Enter.

The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to Finalpole2.
g. ClickOK.

A cylinder called Finalpole2 is drawn.

2. Intersect Inner_arm and the new Finalpole2 object:
a. In the history tree, select the Inner_arm object, press and hold down the Ctrl key,

and then select Finalpole2.
b. SelectModeler > Boolean > Intersect.

3. Rotate the Inner_arm object by 29 degrees:
a. In the history tree, right-click Inner_arm, and select Edit > Arrange > Rotate.
b. In the Rotate dialog box that opens, select the Z axis.
c. For the Angle, enter 29 deg, then clickOK.
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The final armatures should look like the following:

4. Click File > Save to save all of the operations up to this point.

Create the Coils
In this topic, you will learn how to create the coils of the actuator. To create the coils, do the
following:

l Create a new coordinate system (RelativeCS1) so that in the new coordinate system, the
XY plane becomes the median plane of the model.

l Create a cross-section of the coils and sweep it across a path that will create the 3D coils.
l Intersect the coil shape with a cylinder .
l Create a duplicate to achieve the final coil shape.

Create the New Coordinate System
1. SelectModeler > Coordinate System > Create > Relative CS > Offset.
2. Press the Tab key to switch to the keyboard entry area of the Status Bar.

Creating the Geometric Model 3-13

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: Designing a Rotational Actuator

3. Type the new origin (0, 0, 12.7) in the (X, Y, Z) boxes and then press Enter.

The new coordinate system is created and named RelativeCS1.

Sweep a Cross-Section across a New Path
The coil(s) are created by sweeping the coil cross-section along a path as follows:

l Set the Drawing Plane to ZX
l Draw the Sweep Path
l Set the Drawing Plane to YZ
l Draw the Cross-Section of the Coil
l Sweep the Cross-Section Along the Path
l Set the Drawing Plane Back to ZX

Draw the Sweep Path in the XZ Plane

To create the path you want to use as the sweep path:

1. SelectModeler >Grid Plane > XZ.
2. Click Draw > Rectangle.
3. Tab to the keyboard entry area and type (-17, 0, -15.5) in the (X, Y, Z) boxes, for the

rectangle position, and then press Enter.
4. Type (34, 0, 31) in the (dX, dY, dZ) boxes, for the rectangle dimensions, and press Enter.

The Properties window appears.

5. Click the Attribute tab.
6. Change the Name to Path, and press Enter.
7. ClickOK.

A rectangle named Path is drawn.

8. Uncover the faces:
a. Click Edit > Selection Mode > Faces, and select path by clicking on it in the

Modeler window.
b. ClickModeler > Surface > Uncover Faces.

Draw the Cross-Section of the Coil in the YZ Plane

To draw the cross-section of the coil:

1. SelectModeler >Grid Plane > YZ.
2. Click Draw > Rectangle to draw the cross-section of the coil.
3. Type (0, 0, 15.5) in the (X, Y, Z) boxes, for the rectangle position, and then press Enter.

Creating the Geometric Model 3-14

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

SettheDrawingPlanetoZX.htm
SettheDrawingPlanetoYZ.htm


Getting Started with Maxwell®: Designing a Rotational Actuator

4. Type (0, 17, 24) in the (dX, dY, dZ) boxes, for the rectangle dimensions, and press Enter.

The Properties window appears.

5. In the Properties window, click the Attribute tab.
6. Change the Name to Coil1, then press Enter.

A rectangle named Coil1 is drawn.

Sweep the Cross-Section Along the Path

To sweep the cross-section (Coil1) along the path (Path) to create the coil:

1. In the history tree, select Path, press and hold down the Ctrl key, and then select Coil1.
2. Click Draw > Sweep > Along Path.

The Sweep along path dialog box appears.

3. ClickOK to accept the defaults.

The Properties window appears.

4. ClickOK to create the coil. The coil retains the name Coil1 from the cross-section used to
create it.
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Set the Drawing Plane Back to XZ

To set the drawing plane:

l SelectModeler > Grid Plane > XZ.

Intersect the Coil Shape with a Cylinder
1. Create a cylinder at the origin with a radius (dZ) of 43mm and a height (dY) of 17mm:

a. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawingmode.

b. Select the center of the cylinder by clicking at the (0,0,0) location, which is the origin
for the coordinate system.

c. Type 43 for the radius in the dZ box at the bottom of the screen, and press Enter.
d. Type 17 for the height in the dY box, and press Enter.
e. In the Properties window, click the Attribute tab.
f. Change the Name to Round.

A cylinder named Round is drawn.

2. Intersect the coil and the new cylinder:
a. In the history tree, select Coil1, press and hold down the Ctrl key, and then select

Round.
b. ClickModeler > Boolean > Intersect.

The intersected object is named Coil1.

Move the Coil into the Final Position
To move the coil into its final position.

1. Select Coil1 in the history tree window.
2. Select Edit > Arrange >Move.
3. Type (0, 0, 0) in the (X, Y, Z) fields, for the origin of the new location, and then press

Enter.
4. Type (0, 54.5, 0) in the (dX, dY, dZ) fields, as the target point of new dimensions, and

press Enter.

Create a Mirror Duplicate of the Coil
To create a second coil by mirroring the first:

1. Select Coil1 in the history tree window.
2. Select Edit > Duplicate >Mirror.
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3. Type (0, 0, 0) in the (X, Y, Z) fields as the coordinates of the anchor point on the mirror
plane, and then press Enter.

4. Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of the target point of the vector
normal to the mirror plane, and press Enter.

A second coil is created and named Coil1_1. The geometry should appear as shown
below:

Create the Coil Terminals
To create the terminals for the coils:

1. In the history tree, select Coil1, press and hold down the Ctrl key, and select Coil1_1.
2. ClickModeler > Surface > Section.
3. Select XY as the Section Plane.
4. ClickOK.
5. ClickModeler > Boolean > Separate Bodies. This separates the interlinked sheet

objects created when the intersection of the XY plane created two terminals in each coil.
The resulting four objects are automatically named:

l Coil1_Section1
l Coil1_Section1_Separate1
l Coil1_1_Section1
l Coil1_1_Section1_Separate1

6. Delete the two redundant terminals:
a. In the history tree, select Coil1_Section1_Separate1, press and hold down the

Ctrl key, and select Coil1_1_Section1_Separate1.
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b. Press Delete.
7. Select Coil1_Section1 in the Sheets section of the history tree.
8. Change the name of Coil1_Section1 to Section1 and press Enter.
9. Select Coil1_1_Section1, and change its name to Section2.

Create the Background (Region)
Define a background region box with the origin at (-250, -250, -250) and the dimensions of (500,
500, 500).

To create the background region box:

1. Click Draw > Box.
2. Type the box position (-250, -250, -250) in the X, Y, and Z fields at the bottom of the

screen, and then press Enter.
3. Type the box size (500, 500, 500) in the dX, dY, dZ fields, and then press Enter.
4. In the Properties window's Attribute tab, change the Name (currently Box3) to Bgnd.
5. Set the transparency to 0.9:

a. Click the button for the Transparent property.

The Set Transparency dialog box appears.

b. Type 0.9 in the text box, and clickOK to return to the Properties window.

A box named Bgnd is drawn.

Note: Alternatively, the Draw > Region command may be used to create the
background object.

6. Press Ctrl-D to fit the drawing in the window.

The final geometry should look similar to the following:
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Parameterize the Model
To finalize the geometry:

1. Select the Inner_arm object in the history tree.
2. Click Edit > Arrange > Rotate.

The Rotate dialog box appears.

3. Select the Z radio button for the Axis.
4. Thinking ahead, we will want to evaluate the device over a range of armature angles.

Therefore, enter “Angle” into the value field and clickOK.

The Add Variable dialog appears as shown to specify the value for the variable.
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5. Ensure that the Unit Type is set to Angle, and the Unit is set to deg. Type 29 in the Value
text box.

6. ClickOK.

Note: Most numeric entry fields allow entry of a variable name for use in
parametric or optimization.

7. Click File > Save to save the final version of the model before moving on to defining
materials.
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4 - Defining Material Properties
Default material properties are automatically assigned when you create the geometry objects.
You can view these properties by viewing the Attribute tab of the Properties window. The
default material for all objects is vacuum, which can be changed as soon as you draw an object.
For this example, you will set the material definitions for all objects at the same time after the
entire geometry has been created.

In this chapter you will complete the following tasks:

l Assign nonlinear material to armatures

l Assign steel material to other objects

Define the Nonlinear Material for Armatures
To define the nonlinear material for the armatures:

1. Double-click theOuter_arm object in the history tree.

The Properties window appears.

2. Go to the Properties window.
3. In theMaterial row, click the value in the Value column.

A drop-down list appears.

4. Select the Edit... item in the list.

The Select Definition dialog box appears.

5. On theMaterials tab, click the Add Material button.

The View / Edit Material dialog box appears.

6. Type arm_steel in theMaterial Name box.
7. Do the following in the Properties of the Material section:

a. In the Type column of the Relative Permeability row, select Nonlinear from the
drop-down list.

b. In the Value column of the Relative Permeability row, click the BH Curve button.

The BH Curve dialog box appears. By default, 10 rows are available to enter data
points, but this example requires 20.

c. In the Coordinates section, append 10 additional rows to the table to reach a total
of 20 data rows:

i. Click the Append Rows button.
ii. Type 10 in the Number of rows text box, and clickOK.
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The BH Curve dialog box reappears, with 20 rows now available in the table.

d. Type the following H and B data in the Coordinates section:

Note:When entering data into the Coordinates section, the Tab key can
be used to sequentially move to the next entry position.

H (A/m) B (T)
1. 0 0
2. 4000 1.413
3. 8010 1.594
4. 16010 1.751
5. 24020 1.839
6. 32030 1.896
7. 40030 1.936
8. 48040 1.967
9. 64050 2.008
10. 80070 2.042
11. 96080 2.073
12. 112100 2.101
13. 128110 2.127
14. 144120 2.151
15. 176150 2.197
16. 208180 2.24
17. 272230 2.325
18. 304260 2.37
19. 336290 2.42
20. 396000 2.5
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The curve should appear as shown below:

e. ClickOK.

The BH Curve dialog box closes, and the View / Edit Material dialog box
reappears.

f. In the Value column of the Bulk Conductivity row, enter 2e6.
g. In the bottom right of the View / Edit Material dialog box, click Validate Material.

A green check mark appears if the material is valid.

8. ClickOK to close the View / Edit Material dialog box.

The Select Definition dialog box reappears.

9. ClickOK to close the Select Definition dialog box.

Assign Material Properties for Other Objects
Select the Inner_arm object, and assign the newly defined arm_steel property. Select the two
coils, and assign copper as the material property:

To assign the material properties to the model objects:
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1. Select the Inner_arm object in the history tree.
2. In the Properties window'sMaterial row, click the field in the Value column.

A drop-down list of available materials appears.

3. Select arm_steel from the list of materials.
4. Repeat steps 1 through 3 to assign copper to Coil1.
5. Repeat steps 1 through 3 to assign copper to Coil1_1.
6. Leave the material assignment for the Bgnd object unchanged.
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5 - Setting Up and Running the Analysis
In this chapter you will complete the following tasks:

l Set up excitations and calculations
l Set up the analysis
l Run and solve the analysis

Assign Excitations
Currents need to be defined and assigned as excitations for the two coil terminals.

To define the currents:

1. Select Section1 and Section2 in the history tree.
2. ClickMaxwell 3D > Excitations > Assign > Current from the menu.

The Current Excitation dialog box appears.

Note: Excitations may also be assigned using the shortcut menu. Right-click on
Excitations in the Project Manager tree. In the Shortcut menu, select Assign >
Current.

3. Type 675.5 in the Value text box, and select A as the units.
4. Select Stranded as the Type.
5. ClickOK.

By default, all faces of the region box (Bgnd) are assigned with magnetic flux tangent boundary
conditions. Therefore, no additional boundary conditions are required for this example problem.

Set Up Parameter Calculations
In this example, you will calculate the torque and inductance matrix parameters.

Set Up the Torque Calculation
To set up the torque calculation:

1. Select the Inner_arm object by clicking its name in the history tree.
2. In the Project Manager tree, expand the model until you see the Parameters entry.
3. Right-click Parameters and select Assign > Torque from the shortcut menu.

The Torque dialog box appears.
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4. Leave the Type set to Virtual.
5. SelectGlobal:Z from the Axis drop-down list.
6. Select the Positive radio button for the axis orientation.
7. ClickOK.

Set Up the Inductance Matrix Calculation
To set up the inductance matrix calculation:

1. Right-click the Parameters entry in the Project Manager tree, and select Assign >Matrix
from the shortcut menu.

TheMatrix dialog box appears.

2. Click the Setup tab.
3. Select Include for both Coil1 and Coil1_1 for the inductance calculations to be

performed. The self inductances and mutual inductances will be calculated.
4. ClickOK.

Exploring the Matrix Setup Grouping Functionality
The matrix setup provides a grouping functionality on the Post Processing tab:

Thus, in addition to inductance matrix entries calculation, Maxwell can perform a grouping
calculation.
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To perform a grouping calculation:

1. Select the matrix entry and specify the corresponding number of turns.
2. Select all matrix entries to be involved in grouping and click theGroup button.
3. Specify the number of branches.

The operations performed by the grouping function can be one of the following three cases:

l Series connection if the number of branches is set to 1.
l Parallel connection if number of branches is equal with the total number of coils (matrix
entries).

l Series/parallel if the number of branches is different from the two above.

Example 1: Series/Parallel

Assume a situation with 4 coils, each with 18 turns, all 4 selected to be grouped with the number
of branches set to 2. In this case, 9 turns from each of the 4 coils (18 / 2 branches = 9) are
connected in series and paralleled, with the other 9 turns of the same coils also connected in
series.

Example 2: Series/Parallel

Assume a situation with 5 coils, each with 15 turns and number of branches set to 3. In this case,
the equivalent S/P corresponds to taking the first 5 turns from each of the 5 coils and connecting
them in series, taking the next 5 turns from the same coils and connecting them in series, taking
the final 5 turns from the coils and connecting them in series, and then finally connecting the
emerging 3 subgroups in parallel.

Note: For the grouping in the S/P case to correspond to a physical situation, the
number of turns must be an integer multiple of the number of branches.

Set Up the Analysis
To set up the analysis:

1. Right-click the Analysis entry in the Project Manager tree, and select Add Solution
Setup.

The Solve Setup dialog box appears.

2. Click theGeneral tab.
3. Accept the default values (Maximum number of passes = 10 and Percent Error = 1).

These settings instruct the solver to solve up to 10 passes as the automatic adaptive
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mesh refinement refines the mesh and improves the accuracy of the solution at run time.

4. ClickOK.

Validate Design
Before running a simulation, it is best to validate its setup.

1. From theMaxwell 3Dmenu, select Validate Check. Alternatively, from the Simulation

tab, you can click the Validate icon.

The Validate Check tool runs, and after it is complete, the Validate Check window appears:

For this model, we see that the model, the design settings, and the simulation parameters were
checked and validated. If the tool finds any problem with your design, it will be reported in this
window. Make sure to address any of these issues before you run your simulation.

Run the Analysis
To run the analysis:

1. Right-click the Analysis entry in the Project Manager tree, and select Analyze.
2. To visualize the progress of the solution:

a. Right-click the Setup1 field (located under the Analysis field), and select
Convergence.

b. Make sure the Convergence tab is selected.
c. Select a tabular or graphical format for how to visualize the information about the
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energy, number of finite elements, torque, etc.
d. ClickOK.

3. When the solution is complete (it should take between 3 and 5 minutes on most PCs), look
at the value of the torque from LastAdaptive.

The value should be about -0.19835 N m.
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6 - Postprocessing the Results
In this chapter you will complete the following tasks:

l Plot the magnetic flux density vector
l Plot the magnetic flux density magnitude

Plot the Magnetic Flux Density Vector
Plot the flux density vector on the mid-vertical symmetry plane of the device. You previously set
up a relative coordinate system (RelativeCS1) containing the desired plot plane.

Create an Object List
The plot results for the two armatures are of interest, so you will create a list of these two objects
to plot only those results.

To create the list of objects:

1. Select theOuter_arm and Inner_arm objects.
2. ClickModeler > List > Create >Object List.

ObjectList1 is created under the Lists section of the history tree.

Plot the Quantity
To create the plot:

1. Change the rendering of objects in the model to wireframe by clicking View > Render >
Wire Frame.

2. In the history tree, expand the Planes entry and select the RelativeCS1:XY plane. This
will be the plane to create plots on.

3. In the Project Manager tree, right-click Field Overlays, and select Fields > B > B_Vector.
The Create Field Plot dialog box appears.

4. Make sure B_Vector is selected in theQuantity list.
5. SelectObjectlist1 in the In Volume list.
6. Click Done.
7. ClickMaxwell 3D > Fields >Modify Plot Attributes.

The Select Plot Folder dialog box appears.

8. Click the Plots tab.
9. Under the Vector Plot parameters, enter 4 in themin box.
10. Click Apply, and then click Close.

Getting Started with Maxwell®: Designing a Rotational Actuator

Post Processing the Results 6-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: Designing a Rotational Actuator

The plot should look similar to the following figure:

Plot the Magnetic Flux Density Magnitude
To avoid overlapping with the previous plot, right-click the name of the previous plot (B_Vector)
under Field Overlays, and uncheck the Plot Visibility box.

1. Follow the procedure used to create the previous plot to plot the magnetic flux density
magnitude (B_Mag) on the same XY plane of the RelativeCS1 coordinate system.

2. In the Project Manager tree, expand Field Overlays, and then the B entry.
3. Double-clickMag_B1 to plot the B Magnitude results.
4. Once the plot is displayed, right-click in the color key and selectModify.
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5. In the Scale tab, set the Number of divisions to 250 to get a smooth plot.
6. Click Close.

The plot should look similar to the following figure:
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7 - Running a Parametric Analysis
In this chapter you will complete the following tasks:

l Run a parametric analysis
l Create an analysis report
l Close the project and exit Maxwell

Parameterization and Parametric Analysis

Parameters can be easily added to the setup for the purpose of changing assigned values
(making "what if" type of analysis easy to perform), which in turn, makes it easier to set up and
run a parametric analysis. The quantities that can be parameterized include geometric attributes,
material properties, excitations, etc.

In this application, we define the rotation angle of the Inner_arm object as a parameter and then
perform a parametric analysis aimed at obtaining the self and mutual inductance of the two coils
as well as the torque for a whole range of rotation angles. The rotation angle was specified as a
variable during the creation of the geometric model.

To define the angle variable as a design parameter:

1. In the Project Manager tree, right-click theOptimetrics entry and select Add >
Parametric.

2. In the Setup Sweep Analysis dialog, click Add to add a variable to the sweep.
3. Select the variable Angle from the drop-down list.
4. Select Linear Step as the type of sweep.
5. Enter 0 deg for the Start value, 30 deg for the Stop value, and 5 deg for the Step value.
6. Click the Add button, and thenOK.
7. Select the Calculations tab.
8. Click the Setup Calculations button.
9. In the Add/Edit Calculation window, selectMagnetostatic for Report Type, Setup1:

LastAdaptive for Solution, and None for Parameter.
10. From the Trace tab, under Category, select the following variables:

a. Select Torque > Torque1.Torque and click Add Calculation.
b. Select L >Matrix1.L(Current_1, Current_1) and click Add Calculation.
c. Select L >Matrix1.L(Current_1, Current_2) and click Add Calculation.
d. Select L >Matrix1.L(Current_2, Current_2) and click Add Calculation.

11. Click Done.
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12. Back in the Setup Sweep Analysis window, select theOptions tab.
13. Select the Save Fields And Mesh check box.
14. ClickOK when complete.

A ParametricSetupn entry is now shown under Optimetrics in the project tree.

To start the parametric analysis:

1. Right-click the ParametricSetup1 entry in the Project Manager tree, and select Analyze.

Note: Because you are solving multiple geometric problems, the solution time
required will be proportionately longer than solving the non-parametric solution in
the previous chapter.

Create a Parametric Analysis Report
Once the parametric analysis in complete, create analysis report:

To create a report:

1. In the Project Manager tree, right-click the Results entry and select Create
Magnetostatic Report > Rectangular Plot.

2. In the New Report window set the Solution to Setup1:LastAdaptive and Parameter to
None.

3. Under Category select L and hold down the Ctrl key and selectMatrix1.L(Current_
1,Current_1),Matrix1.L(Current_1,Current_2),Matrix1.L(Current_2,Current_1), and
Matrix1.L(Current_2,Current_2), then click New Report.

4. Click Close when finished.
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The plot should look similar to the following figure.

The L11 and L22 traces overlap. This is normal because the respective inductances should be
identical.

Create an Animation Using Saved Parametric Field Data
You can perform an animation using the saved data.

To perform an animation:

1. In the Project Manager tree, under Field Overlays, select the desired field plot that is to
be animated (such as the B vector field plot created in chapter 6).

2. Right-click the plot, and select Animate.

The Setup Animation dialog box appears.

3. If only one variable is available, click Animate.
4. If more than one variable is available, click the Swept Variable tab.
5. Select the desired variable from the Swept variable drop-down menu (angle in this

case).
6. Select the desired variations from the Select values section.
7. ClickOK to start the animation process.

The Animation play panel appears, allowing you to pause and otherwise control the
animation.

8. Click Close to stop the animation display.
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Note: You can export the animation as an animated .gif or .avi file by clicking Export
in the Animation play panel.

Note: Maxwell can take advantage of computing resources on various computers that
can be accessed on a local network. Using the High Performance Computing (HPC)
feature, you can solve parametric designs in parallel (simultaneously) on multiple user-
selected computers available on the local network. Please contact your account
manager for details.
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8 - Close the Project and Exit Electronics
Desktop

Congratulations! You have successfully completedGetting Started with Maxwell: Designing a
Rotational Actuator. You may close the project and exit the Ansys Electronics Desktop software.

1. Click File > Save to save the project.
2. Click File > Close.
3. Click File > Exit to exit Electronics Desktop.
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